Cub 185 Lo Boy

IH CUB Lo-Boy Series - 154, 184, 185 Forum -- Questions and answers to all of your Lo-Boy related issues.
Forum rules
Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
roberge4026@gmail.com
Posts: 1
Joined: Thu Aug 03, 2023 1:13 pm
Zip Code: 43221

Cub 185 Lo Boy

Postby roberge4026@gmail.com » Thu Aug 03, 2023 1:29 pm

Seeking help w/following problem with 185 Lo Boy: Problem began this spring. After about 30 minutes, engine quits, and the coil is ultra hot to the touch. After a few hours to let the coil cool, engine starts and runs fine, but after about 30 minutes, it quits again, and the coil is ultra hot. Checked spark plugs/wires, fuel system/carb, cooling system. All OK.

Installed new coil, points, condenser, rotor and distributor cap. Same problem. Checked spark plug firing with a light w/following results. When engine is running normally, light indicates normal (timed) firing of spark plugs. But, after engine quits (with hot coil), the spark plugs fire at random, and not in time with rotor rotation. I'm at wit's end. Has anybody got any ideas??
Thanks,
Pat
Columbus, OH

outdoors4evr
10+ Years
10+ Years
Posts: 2781
Joined: Tue Jul 22, 2008 12:44 pm
Zip Code: 48370
Tractors Owned: 184
Location: Oxford, MI

Re: Cub 185 Lo Boy

Postby outdoors4evr » Tue Aug 08, 2023 7:30 am

Sounds like you either purchased a new bad coil or perhaps you installed a 6v coil and need a 12v coil (one with an internal resistor). Might want to either try adding a ballast resistor before the coil or replacing the coil again with an internally resisted coil.
184 w/ Creeper & 3-Point
IH 3160a Mower
IH Model 15 Tiller
IH-54 Blade


Return to “Lo-Boy Series - 154, 184, 185”

Who is online

Users browsing this forum: No registered users and 1 guest