New To Me 1966 IH 504

All other non-specific model Farmall / IH / CASE tractors. (Catch-All)

Moderator: Team Cub

Forum rules
Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.

Re: New To Me 1966 IH 504

Postby Florida 504 » Thu Sep 12, 2013 6:19 pm

Thanks Sonny, no rush.
Removed the pump today, looks brand new however how bad can it look submersed in oil.

It is a Cessna pump and stamped on it was J 01 GS, could that be a build date on the pump meaning it has already been replaced in 2001?
I keep reading about a piggy back pump but only appeared to be the single pump. Should there be another one since i have a loader?
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Re: New To Me 1966 IH 504

Postby SONNY » Thu Sep 12, 2013 11:12 pm

Some of them ran front mount pumps,--but not always. I see them both ways!----had one on the 404,sold the loader a long time ago.
My 574 had the loader hooked to the internal pump and used wobble stick for loader control. Ingot rid of that loader last year!----have tractor engine ready to go back in. Thanks; sonny
SONNY
501 Club
501 Club
 
Posts: 2159
Joined: Thu Nov 09, 2006 11:26 pm
Zip Code: 00000

Re: New To Me 1966 IH 504

Postby SONNY » Fri Sep 13, 2013 12:05 am

some had two pumps,---some had only one, depending on what the first owner intended on using the tractor for,--so you may have gotten a tractor with only one pump because original byer had no intention of ever putting a loader on the tractor. thanks; sonny
SONNY
501 Club
501 Club
 
Posts: 2159
Joined: Thu Nov 09, 2006 11:26 pm
Zip Code: 00000

Re: New To Me 1966 IH 504

Postby Florida 504 » Fri Sep 13, 2013 6:19 pm

OK so where would the 2nd pump be? Attached to the other one? Can i add the 2nd one?
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Re: New To Me 1966 IH 504

Postby Florida 504 » Fri Sep 13, 2013 6:25 pm

SONNY wrote:----have tractor engine ready to go back in. Thanks; sonny


Pics, we need pics!
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Re: New To Me 1966 IH 504

Postby Florida 504 » Sun Sep 15, 2013 11:21 am

Took off the cover from under the seat.

Image

This area is full of sludge, is it ok to pour some kero in here and try to clean it?
In the top right corner of this picture there is a tall silver plug that appears to be a drain into the lower area, will this allow the kero to drain into the lower section and eventually drain out the plug under the rear?

The brakes never worked well, if i pull the covers springs won't go flying will they?
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Re: New To Me 1966 IH 504

Postby SONNY » Thu Sep 19, 2013 8:22 am

The brakes on these tractors are disk type and dont work too well!---if they get grease/oil on them, they dont work at all 4 bolts takes the cover loose and then you have to unhook the peddle link!--NO parts fly out,---quite simple set-up once you get in there! thanks; sonny
SONNY
501 Club
501 Club
 
Posts: 2159
Joined: Thu Nov 09, 2006 11:26 pm
Zip Code: 00000

Re: New To Me 1966 IH 504

Postby Florida 504 » Sun Nov 03, 2013 8:02 pm

Hey All, got side tracked on other items but its time to get back to work on the 504.
This weekend progress.
I know the fenders are supposed to be red but i thought the white would offset oll the red on the loader,

Image

Image

Image

Image

Image

Image
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Re: New To Me 1966 IH 504

Postby CubitisNH » Sun Nov 03, 2013 8:30 pm

Your 504 looks to be coming along nicely. I hadn't looked at this topic for a while,hope by now you've found the other hydraulic pump. My 504 utility has 3-one out front for the loader,main pump for tractor hydraulics,and one for power steering. Suffix on serial tag (letters) tells what you have in this case. Suffix code is in Ken Updike's serial# book. Hope this helps.
Mike
How can you have too many Cubs????
CubitisNH
501 Club
501 Club
 
Posts: 565
Joined: Sun May 14, 2006 3:59 pm
Location: Plymouth,NH
Zip Code: 00000
Circle of Safety Award
Circle of Safety: Y

Re: New To Me 1966 IH 504

Postby Florida 504 » Wed Nov 13, 2013 6:34 pm

Does anyone have a picture of the dash for a 504?
There is a light at the top and i was wondering if it was supposed to have a cover and if so what does it look like.
I would also like a picture of the battery box cover, mine is missing and i was going to make a new one but have no idea what it looks like.
Thanks
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Re: New To Me 1966 IH 504

Postby Tezell » Thu Nov 14, 2013 8:09 am

I don't know anything about a 504 but that one is starting to look good!
"I ain't believing this!"
User avatar
Tezell
501 Club
501 Club
 
Posts: 1971
Joined: Fri Sep 10, 2010 5:23 pm
Location: Jakin Georgia
Zip Code: 39861
Tractors Owned: 51 Cub
"Jacksonville" 53 Cub
"Dale" 53 Cub Fast Hitch
"Louie" 64 Cub Fast Hitch
"Elmore"71 Cub
"Paw Paw"71 Cub Fast
Hitch
"Ugly" 75 Cub
John Deere 2003 - 5320
Circle of Safety Award
Circle of Safety: Y

Re: New To Me 1966 IH 504

Postby Florida 504 » Thu Nov 14, 2013 6:44 pm

Its getting there.

This is how far i got this weekend.

Image


Got the instrument cluster mostly finished tonight, guess i should have got a new Amp gauge also.

Image

If the weather is good i may get to hear it run again by the end of this weekend.
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Re: New To Me 1966 IH 504

Postby Florida 504 » Sun Nov 17, 2013 7:16 pm

Florida 504 wrote:(reply to post at 16:50:58 11/14/13)


Made good progress this weekend, mostly together and got it running. Still need to finish setting up the loader.
It fought me every step of the way but its 47 years old so i expected that.

I have 1 issue i need some help with. I have traced everything down following the wiring diagram and it all looks good.
When i hooked up the battery cable the generator started spinning. Went back and looked at all the wires, found a couple cracked casings so i repaired or replaced them as needed but when i give it power it still spins.

I finally took off the top wire from the voltage regulator and it stopped. It will start and run with this wire off but i assume it won't charge.
Could a bad voltage regulator cause this? It was fine before i took it apart.
Any other ideas?

Image

Image
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Re: New To Me 1966 IH 504

Postby Florida 504 » Mon Nov 25, 2013 6:28 pm

I did get it all back together and was nice to be able to use it again this weekend.
Got it all covered in dust using the bush hog and grading my road, the dirtier it got the better it ran.
Still having hydraulic issues and its not charging but i will get it figured out and better then new.


Here You Go.
I took these tonight, started to get dark so i had to use the flash.

Image

Image

Image

Image
Florida 504
 
Posts: 16
Joined: Wed Aug 28, 2013 7:11 pm
Zip Code: 32303

Previous

Return to Farmall / IH / CASE

Who is online

Users browsing this forum: No registered users and 2 guests